我正在尝试使用EF核心迁移功能。 但是,当我从NuGet安装dotnet-ef工具时,抛出以下错误消息。 我的应用程序版本是netcoreapp3.0。

dotnet tool install --global dotnet-ef --version 3.1.0-preview3.19554.8 

错误NU1202:软件包dotnet-ef 3.1.0-preview3.19554.8与netcoreapp3.0(.NETCoreApp,Version = v3.0)/任何版本都不兼容。 软件包dotnet-ef 3.1.0-preview3.19554.8支持:netcoreapp3.1(.NETCoreApp,Version = v3.1)/任何

旧版本仅支持netcoreapp2.1

dotnet tool install --global dotnet-ef --version 3.0.1 

错误NU1202:软件包dotnet-ef 3.0.1与netcoreapp3.0(.NETCoreApp,Version = v3.0)/任何版本都不兼容。 软件包dotnet-ef 3.0.1支持:netcoreapp2.1(.NETCoreApp,Version = v2.1)

实际上哪个dotnet-ef版本支持netcoreapp3.0有什么想法吗?

===============>>#1 票数:0

请检查此问题及其答案: 更新.NET Core工具

正如对该问题的答案所指出的那样,这似乎是一个已知的错误: https : //github.com/dotnet/cli/issues/12963

发布该问题的人回答了他们发现的解决方法。 也许它也会为您服务。

  ask by Deepak Koshy translate from so

===============>>#2 票数:0

这对我有用

dotnet tool install --global dotnet-ef --version 3.0.0 

  ask by Deepak Koshy translate from so

本文未有回复,本站智能推荐: